امنیتوردپرس
موضوعات داغ

آسیب پذیری های کشف شده در وردپرس (March 2021)

مثل هر ماه، در سومین ماه میلادی سال ۲۰۲۱ (مارچ) نیز همانند ماه‌های گذشته، آسیب پذیری‌های مختلفی از جمله SQL Injection، Authentication Bypass، RCE و … در پلاگین‌ها و تم‌های وردپرسی زیادی کشف شده است. در ادامه راجع به جزئیات آن‌ها به‌طور مفصل صحبت خواهیم کرد.

لطفاً تا پایان این مطلب با ما همراه باشید و در صورتی که از هرکدام از این موارد در وبسایت خود استفاده می‌کنید، بلافاصله آن را به آخرین نسخه به‌روزرسانی کنید تا سایت و کسب‌و‌کار اینترنتی‌تان با مشکلی از لحاظ امنیت مواجه نشود. اجازه دهید ابتدا سراغ پلاگین‌ها و آسیب پذیری‌های‌شان برویم.

آسیب پذیری‌های کشف شده در پلاگین‌های وردپرس

مطابق معمول، بسیاری از آسیب‌پذیری‌های کشف شده در سیستم مدیریت محتوای وردپرس، مربوط به پلاگین‌های آن هستند:

آسیب پذیری XSS در پلاگین Woocommerce Customers Manager

پارامترهای wccm_customers_ids و wccm_customers_emails به‌درستی توسط تابع sanitize_text_field() فیلتر نمی‌شوند و این موضوع منجر به حمله reflected XSS می‌شود.

نسخه‌های آسیب پذیر در این پلاگین: ۲۶.۶ و ما قبل آن

میزبان هاست سوشال

آسیب پذیری CSRF در پلاگین Woocommerce Customers Manager

عملیات AJAX که در قسمت upload_csv برای کاربران authenticate شده فراهم است، به‌دلیل عدم بررسی مناسب CSRF، قابلیت اجرای این حمله (CSRF) را فراهم می‌کند و مهاجم با استفاده از آن می‌تواند، اکانت‌هایی با سطح دسترسی administrator ایجاد کند.

نسخه‌های آسیب پذیر در این پلاگین: ۲۶.۶ و ما قبل آن

آسیب پذیری XSS در پلاگین Ivory Search

صفحه search این افزونه، به‌دلیل عدم sanitize مناسب ورودی‌های کاربر، اجرای حمله reflected XSS را برای مهاجم ممکن خواهد کرد.

نسخه‌های آسیب پذیر در این پلاگین: ۴.۶.۱ و ما قبل آن

آسیب پذیری XSS در پلاگین Cooked Pro

در این پلاگین، ورودی‌های کاربر به‌درستی sanitize نمی‌شوند و همین موضوع امکان اجرای حمله Reflected XSS را فراهم می‌کند.

سرورهای مجازی میزبان هاست

نسخه‌های آسیب پذیر در این پلاگین: ۱.۷.۵.۶ و ما قبل آن

آسیب پذیری XSS در پلاگین Advanced Booking Calendar

پیغام license error در این پلاگین، هنگام نمایش در صفحه settings به‌درستی فیلتر نشده است. به همین خاطر و با استفاده از این ایراد، می‌‎توان حمله Reflected XSS را اجرا کرد.

نسخه‌های آسیب پذیر در این پلاگین: ۱.۶.۸ و ما قبل آن

آسیب پذیری Improper Access Control در پلاگین Controlled Admin Access

این پلاگین به‌شکل صحیح دسترسی کاربران محدود شده را بررسی نمی‌کند و این موضوع باعث می‌شود تا بتوان به صفحاتی که نباید اجاره دسترسی به آن‌ها وجود داشته باشد، request ارسال کرد. خلاصه اینکه مهاجم می‌تواند با استفاده از این آسیب پذیری، یک کاربر administrator با دسترسی کامل به blog ایجاد کند.

نسخه‌های آسیب پذیر در این پلاگین: ۱.۵.۶ و ما قبل آن

اپلیکیشن میزبان هاست

آسیب پذیری XSS در پلاگین Advanced Booking Calendar

عدم sanitize مناسب ورودی‌های در صفحه Seasons & Calendars، منجر به حمله Reflected XSS می‌شود.

نسخه‌های آسیب پذیر در این پلاگین: ۱.۶.۷ و ما قبل آن

آسیب پذیری Unauthorized AJAX calls در پلاگین Easy Form Builder

تمامی عملیات‌های AJAX در این پلاگین، بدون بررسی مجوزها انجام می‌شوند! به این ترتیب، کاربران با هر سطح دسترسی، می‌توانند آن‌ها را فراخوانی و تغییرات دلخواه را در فرم‌های مدنظر اعمال کنند. تغییراتی مثل حذف یا ویرایش اطلاعات موجود.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری XSS در پلاگین Patreon WordPress

در پلاگین Patreon WordPress آسیب پذیری XSS به دو صورت رخ می‌دهد:

میزبان هاست راهکار جامع شبکه و وب
  1. در عملیات AJAX قسمت patreon_save_attachment_patreon_level آسیب پذیری Reflrected XSS کشف شده است. این action برای کاربرانی که مجوز manage_options را داشته باشند، فعال است.
  2. در Login Form این پلاگین، آسیب پذیری Reflected XSS کشف شده است. برای اجرای موفق این حمله، attacker یا مهاجم باید قربانی خود را برای باز کردن یک لینک حاوی کدهای مخرب جاوا اسکریپت فریب دهد.

نسخه‌های آسیب پذیر در این پلاگین برای هر دو حالت: ۱.۷.۲ و ما قبل آن

آسیب پذیری CSRF در پلاگین Patreon WordPress

آسیب پذیری CSRF هم در این پلاگین، به دو صورت نمایان می‌شود:

  1. در حالت اول، با استفاده از این آسیب پذیری (CSRF) می‌توان یک کاربر administrator را مجاب کرد تا یک لینک مخرب را باز کند. به این ترتیب، ارتباط سایت با Patreon را قطع خوهد شد.
  2. در حالت دوم، به‌واسطۀ این آسیب پذیری، می‌توان یک کاربر login شده را فریب داد تا metadataهای اکانت خود را تغییر داده یا مقادیر جدیدی را overwrite کند. با exploit کردن این آسیب پذیری می‌توان wp_capabilities که شامل user roles و user privilege است را overwrite کرد. بد نیست بدانید که این موضوع می‌تواند منجر به قطع دسترسی قربانی به سایت و محتوایی که بابت آن هزینه پرداخت کرده است شود.

نسخه‌های آسیب پذیر در این پلاگین برای هر دو حالت: ۱.۷.۰ و ما قبل آن

آسیب پذیری Local File Disclosure در پلاگین Patreon WordPress

این آسیب پذیری توسط هر شخصی که از وبسایت بازدید کند، قابل پیاده سازی است! با سوءاستفاده از آن می‌توان فایل‌های حساس سایت مانند فایل wp-config.php که در آن یوزر و پسورد دیتابیس قرار دارد را مشاهده کرد.

نسخه‌های آسیب پذیر در این پلاگین: ۱.۷.۰ و ما قبل آن

آسیب پذیری Arbitrary File Upload در پلاگین Easy Form Builder

عملیات AJAX در قسمت EFVP_verify_upload_file به‌دلیل عدم بررسی فایل‌های آپلود شده، به کاربران احراز هویت شده و دارای سطح دسترسی پایین اجازه آپلود فایل‌های دلخواه را می‌دهد. این موضوع در نهایت می‌تواند منجر به حمله RCE شود.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری File Upload Arbitrary در پلاگین N5 Upload Form

این پلاگین دارای نقص امنیتی‌ای است که به هکر اجازه آپلود فایل‌های دلخواه خود را می‌دهد. او با استفاده از این رخنه می‌تواند به RCE برسد.

اگر چه نام فایل آپلود شده مشخص نخواهد بود و به صورت md5 و random ایجاد می‌شود، اما در صورت وجود misconfiguration در سرور و فعال بودن Directory Listing، امکان دسترسی به فایل آپلود شده به راحتی میسّر خواهد بود.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری Arbitrary File Download در پلاگین WP-Curriculo Vitae Free

در صفحه‌ای که [formCadastro] قرار گرفته (embed) شده است، به‌تازگی نقص امنیتی‌ای کشف شده است.  نقصی که به‌وسیلۀ آن، هکر می‌تواند پس از ثبت‌نام، در قسمت انتخاب تصویر پروفایل، فایل دلخواه خود را آپلود کرده و در نهایت به RCE برسد.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری SQL Injection در پلاگین Quiz And Survey Master

SQL Injection به دو صورت در این پلاگین ظاهر می‌شود:

  1. تابع qsm_rest_get_bank-questions در فایل php/rest-api.php پارامتر category را قبل از استفاده آن در SQL statementها، به‌درستی فیلتر و escape نمی‌کند. همین ایراد به کاربران با قابلیت دسترسی edit_post (نویسندگان و بالاتر) امکان اجرای حمله SQL Injection را می‌دهد. (نسخه‌های آسیب پذیر در این پلاگین: ۷.۱.۱۴ و ما قبل آن)
  2. در این پلاگین پارامتر result_id به دلیل عدم sanitize مناسب، امکان اجرای حمله SQL Injection را به هکر می‌دهد. برای اجرای موفق این حمله، نیاز به داشتن سطح دسترسی جزئی – مانند Author – وجود دارد و کاربر (هکر) با این آسیب پذیری می‌تواند به DBMS دسترسی پیدا کند. (نسخه‌های آسیب پذیر در این پلاگین: ۷.۱.۱۲ و ما قبل آن)

آسیب پذیری XSS در پلاگین Vertical News Scroller

در حالی که در نسخه ۱.۱۰ این پلاگین سعی شد تا آسیب پذیری Reflected XSS برطرف گردد، اما خب تغییرات کافی نبودند و امکان اجرای این حمله همچنان فراهم است!

نسخه‌های آسیب پذیر در این پلاگین: ۱.۱۷ و ما قبل آن

آسیب پذیری PHP Object Injection در پلاگین Facebook for WordPress

تابع run_action در این پلاگین، داده‌هایی که از طرف کاربر وارد می‌شوند را deserialize می‌کند. به این ترتیب، امکان اجرای حمله PHP object injection فراهم می‌شود.

نسخه‌های آسیب پذیر در این پلاگین: ۳.۰.۰ و ما قبل آن

آسیب پذیری CSRF در پلاگین Facebook for WordPress

عملیات‌های AJAX در قسمت‌های wp_ajax_save_fbe_settings و wp_ajax_delete_fbe_settings در این پلاگین، به‌دلیل عدم وجود nonce protection، دارای آسیب پذیری CSRF هستند. با سوءاستفاده از این آسیب پذیری، امکان اجرای حمله Stored XSS و حذف تنظیمات وجود دارد.

نسخه‌های آسیب پذیر در این پلاگین: ۳.۰.۴ و ما قبل آن

آسیب پذیری Unauthenticated Option Update در تمام پلاگین‌ها و تم‌های Thrive

با استفاده از این آسیب پذیری، هکرها می‌توانند داده‌های دلخواه خود را به option از پیش تعریف شده در جدول wp-options اضافه کنند.

پلاگین‌ها و نسخه‌های آسیب پذیر:

Thrive-ab-page-testing —— رفع شده در نسخه ۱.۴.۱۳.۳

Thrive-comments —— رفع شده در نسخه ۱.۴.۱۵.۳

Thrive-headline-optimizer —— رفع شده در نسخه ۱.۳.۷.۳

Thrive-leads —— رفع شده در نسخه ۲.۳.۹.۴

Thrive-ultimatum —— رفع شده در نسخه ۲.۳.۹.۴

Thrive-quiz-builder —— رفع شده در نسخه ۲.۳.۹.۴

Thrive-apprentice —— رفع شده در نسخه ۲.۳.۹.۴

Thrive-visual-editor —— رفع شده در نسخه ۲.۶.۷.۴

Thrive-dashboard —— رفع شده در نسخه ۲.۳.۹.۳

Thrive-ovation —— رفع شده در نسخه ۲.۴.۵

Thrive-clever-widgets —— رفع شده در نسخه ۱.۵۷.۱

تم‌ها و نسخه‌های آسیب پذیر:

Rise —— رفع شده در نسخه ۲.۰.۰

Ignition —— رفع شده در نسخه ۲.۰.۰

Luxe —— رفع شده در نسخه ۲.۰.۰

Focusblog —— رفع شده در نسخه ۲.۰.۰

Minus —— رفع شده در نسخه ۲.۰.۰

Squared —— رفع شده در نسخه ۲.۰.۰

Voice —— رفع شده در نسخه ۲.۰.۰

Performag —— رفع شده در نسخه ۲.۰.۰

Pressive —— رفع شده در نسخه ۲.۰.۰

Storied —— رفع شده در نسخه ۲.۰.۰

Thrive-theme —— رفع شده در نسخه ۲.۲.۴

آسیب پذیری XSS در پلاگین Mapify Lite

در این پلاگین، Image URL درست فیلتر نمی‌شود و به کاربران با سطح دسترسی editor و بالاتر اجازه استفاده از کدهای مخرب جاوا اسکریپت و حمله Stored XSS را می‌دهد.

نسخه‌های آسیب پذیر در این پلاگین: ۴.۰.۰ و ما قبل آن

آسیب پذیری DoS در پلاگین SecuPress

در هر دو نسخه رایگان و pro این پلاگین، آسیب پذیری‌‌ای وجود دارد که با سوءاستفاده از آن، هر کاربری می‌تواند دسترسی هر IP دلخواه به وبسایت را مسدود کند! در نتیجه، این حمله نوعی حمله‌ی منع سرویس برای IP های Ban شده به حساب می‌آید و آنها امکان بازدید از وبسایت را نخواهند داشت.

نسخه‌های آسیب پذیر در این پلاگین: ۲.۰ و ما قبل آن

آسیب پذیری SSRF در پلاگین Mapplic and Mapplic Lite

با سوءاستفاده از آسیب پذیری SSRF که در این پلاگین یافت شده است، کاربران با سطح دسترسی نویسنده و بالاتر، به‌وسیله یک فایل دلخواه (مثلا SVG)، امکان اجرای حمله Stored XSS را خواهند داشت.

پلاگین‌ها و نسخه‌های آسیب پذیر:

Mapplic-lite —— رفع شده در نسخه ۱.۰.۱

mapplic —— رفع شده در نسخه ۶.۲.۱

آسیب پذیری XSS در پلاگین GiveWP

این پلاگین در صفحه Donors و در پارامتر ‘s’ که جزو انواع GET محسوب می‌شود، دارای آسیب پذیری Reflected XSS است.

نسخه‌های آسیب پذیر در این پلاگین: ۲.۱۰.۰ و ما قبل آن

آسیب‌پذیری Improper Access Control در پلاگین Controlled Admin Access

دسترسی کنترل نشده به global CMS settings و website customization functionality، مانند /wp-admin/customization.php و /wp-admin/options.php می‌تواند مقدمات حمله به سایت را فراهم کند. ساده‌ترین و سریع‌ترین راه برای استفاده از این آسیب پذیری، بالا بردن سطح دسترسی به عنوان administrator و گرفتن کنترل کامل سایت است.

نسخه‌های آسیب پذیر در این پلاگین: ۱.۵.۲ و ما قبل آن

آسیب پذیری Arbitrary File Upload در پلاگین WooCommerce Help Scout

این آسیب پذیری به هکران اجازه آپلود فایل‌های دلخواه‌شان را می‌دهد. این فایل‌ها در مسیر wp-content/uploads/hstmp قرار می‌گیرند و در نهایت با استفاده از این حمله، امکان رسیدن به RCE وجود خواهد داشت.

نسخه‌های آسیب پذیر در این پلاگین: ۲.۹.۱ و ما قبل آن

آسیب پذیری XSS در پلاگین WordPress Related Posts

در صفحه تنظیمات و فیلد title مربوط به آن در این پلاگین، آسیب پذیری Stored XSS کشف شده است. گفتنی است که کاربران با سطح دسترسی admin و بالاتر، امکان اجرای آن را خواهند داشت.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری Open Redirect در پلاگین PhastPress

آسیب پذیری‌ای از نوع Open redirect در این پلاگین کشف شده است. با سوءاستفاده از این آسیب پذیری، می‌توان کاربر را به صفحات مخرب یا جعلی هدایت کرد.

نسخه‌های آسیب پذیر در این پلاگین: ۱.۱۱۱ و ما قبل آن

آسیب پذیری XSS در پلاگین WP Page Builder

ویرایشگر این پلاگین به کاربران با سطح دسترسی پایین امکان تزریق کدهای html و javascript را می‌دهد. این امر امکان اجرای چندین حمله از نوع Stored XSS را فراهم می‌کند.

نسخه‌های آسیب پذیر در این پلاگین: ۱.۲.۴ و ما قبل آن

آسیب پذیری Unauthorize Editing Posts در پلاگین WP Page Builder

تنظیمات پیش‌فرض این پلاگین، به Subscriber ها اجازه ویرایش و تغییر تمام پست‌های سایت را می‌دهد.

نسخه‌های آسیب پذیر در این پلاگین: ۱.۲.۴ و ما قبل آن

آسیب پذیری XSS در پلاگین Elementor

پلاگین یا افزونه Elementor، به شش صورت از  آسیب پذیری XSS تاثیر می‌گیرد:

  1. بخش image box widget در این پلاگین از پارامتر title_size استفاده می‌کند. یک کاربر با سطح دسترسی Contributor یا بالاتر می‌تواند از این پارامتر برای تزریق کدهای مخرب جاوا اسکریپت استفاده کند و حمله Stored XSS را اجرا کند.
  2. قسمت icon box widget در این پلاگین دارای پارامتر title_size است. یک کاربر با سطح دسترسی Contributor یا بالاتر می‌تواند از این پارامتر برای تزریق کدهای مخرب جاوا اسکریپت استفاده کند و حمله Stored XSS را اجرا کند.
  3. بخش accordion widget در فایل includes/widgets/accordion.php، از پارامتر title_html_tag استفاده می‌کند. یک کاربر با سطح دسترسی Contributor یا بالاتر می‌تواند از این پارامتر برای تزریق کدهای مخرب جاوا اسکریپت استفاده کند و حمله Stored XSS را اجرا کند.
  4. بخش divider widget از پارامتر html-tag استفاده می‌کند. یک کاربر با سطح دسترسی Contributor یا بالاتر می‌تواند از این پارامتر برای تزریق کدهای مخرب جاوا اسکریپت استفاده کند و حمله Stored XSS را اجرا کند.
  5. قسمت heading widget که در فایل includes/widgets/heading.php یافت می‌شود، دارای پارامتر header_size است. یک کاربر با سطح دسترسی Contributor یا بالاتر می‌تواند از این پارامتر برای تزریق کدهای مخرب جاوا اسکریپت استفاده کند و حمله Stored XSS را اجرا کند.
  6. بخش column element از پارامتر html_tag استفاده می‌کند. یک کاربر با سطح دسترسی Contributor یا بالاتر می‌تواند از این پارامتر برای تزریق کدهای مخرب جاوا اسکریپت استفاده کند و حمله Stored XSS را اجرا کند.

نسخه‌های آسیب پذیر در این پلاگین در تمام شش حالت: ۳.۱.۲ و ما قبل آن

آسیب‌پذیری Unauthorize Member Join Group در پلاگین BuddyPress

این آسیب پذیری، به دو صورت در پلاگین BuddyPress نمایان می‌شود:

  1. با استفاده از این آسیب پذیری، یک member می‌تواند member دیگری را که عضو گروه دوستانش نیست، برای عضو شدن به یک گروه دعوت کند.
  2. با استفاده از این آسیب پذیری، شخصی که قبلا administrator بوده و به subscriber تنزل پیدا کرده است، همچنان می‌تواند Member type های مربوط به این پلاگین را حذف، ویرایش یا به آن اضافه کند.

نسخه‌های آسیب پذیر در این پلاگین برای هر دو حالت: ۷.۲.۱ و ما قبل آن

آسیب پذیری Unauthorize Read Private Messages در پلاگین BuddyPress

در این پلاگین، آسیب پذیری‌ای کشف شده که به‌وسیلۀ آن یک member می‌تواند رشته پیام‌های خصوصی که به آن‌ها دعوت نشده است را بخواند.

نسخه‌های آسیب پذیر در این پلاگین: ۷.۲.۱ و ما قبل آن

آسیب پذیری Unauthorize Make Friendship در پلاگین BuddyPress

با استفاده از این آسیب پذیری، یک member می‌تواند بدون دخالت member دیگر، او را به گروه دوستان خود اضافه کند و بالعکس.

نسخه‌های آسیب پذیر در این پلاگین: ۷.۲.۱ و ما قبل آن

آسیب پذیری Privilege Escalation در پلاگین BuddyPress

با استفاده از endpoint مربوط به buddypress/v1/members/me، یک کاربر با سطح دسترسی معمولی می‌تواند سطح دسترسی خود را به administrator ارتقا دهد.

نسخه‌های آسیب پذیر در این پلاگین: ۷.۲.۱ و ما قبل آن

آسیب پذیری SQL Injection در پلاگین Paid Membership Pro

به دلیل عدم اعتبارسنجی یا فیلتر مناسب در پارامتر order، امکان اجرای حمله SQL Inejction برای یک کاربر احراز هویت شده فراهم است.

نسخه‌های آسیب پذیر در این پلاگین: ۲.۵.۶ و ما قبل آن

آسیب پذیری SQL Injection Blind در پلاگین wpDataTables

این آسیب پذیری به دو صورت خود را در پلاگین wpDataTables نشان می‌دهد:

  1. این آسیب پذیری مربوط به endpoint موجود در قسمت /wp-admin/admin-ajax.php?action=get_wdtable&table_id=1 و پارامتر length از نوع POST است. این آسیب پذیری به کاربر احراز هویت شده با سطح دسترسی پایین، امکان دسترسی به تمام اطلاعات دیتابیس را می‌دهد. همچنین این آسیب پذیری از نوع Boolean-based است.
  2. این آسیب پذیری مربوط به endpoint موجود در قسمت /wp-admin/admin-ajax.php?action=get_wdtable&table_id=1 و پارامتر start از نوع POST است. این آسیب پذیری به کاربر احراز هویت شده با سطح دسترسی پایین، امکان دسترسی به تمام اطلاعات دیتابیس را می‌دهد. این آسیب پذیری هم از نوع Boolean-based است.

نسخه‌های آسیب پذیر در این پلاگین برای هر دو حالت: ۳.۴.۲ و ما قبل آن

آسیب پذیری Improper Access Control در پلاگین wpDataTables

این آسیب‌پذیری به دو صورت wpDataTables ظاهر می‌شود:

  1. اگر یک کاربر احراز هویت شده با سطح دسترسی پایین، از صفحه‌ای که جدولی در آن منتشر شده بازدید کند، می‌تواند با استفاده از تغییر پارامترهای id_key و id_val، اطلاعات یک کاربر دیگر که در این جدول موجود است را پاک کند. با استفاده از این آسیب پذیری، هکر می‌تواند اطلاعات تمام کاربران جدولی که به آن دسترسی دارد را حذف کند.
  2. با استفاده از این آسیب پذیری، یک کاربر احراز هویت شده با سطح دسترسی پایین، هنگامی که از صفحه‌ای که جدولی در آن منتشر شده است بازدید می‌کند، می‌تواند با تغییر پارامترها، به اطلاعات یک کاربر دیگر که در این جدول است دسترسی داشته باشد و می‌تواند این اطلاعات را تغییر دهد.

نسخه‌های آسیب پذیر در این پلاگین برای هر دو حالت: ۳.۴.۲ و ما قبل آن

آسیب پذیری XSS در پلاگین Flo Forms

این آسیب پذیری، به کاربران با سطح دسترسی پایین این اجازه را می‌دهد که با استفاده از عملیات AJAX در بخش flo_import_forms_options، بتوانند optionهای جدید را import کنند و با تزریق کدهای مخرب جاوا اسکریپت، حمله Stored XSS را پیاده سازی نمایند.

نسخه‌های آسیب پذیر در این پلاگین: ۱.۰.۳۶ و ما قبل آن

آسیب پذیری XSS در پلاگین SEO Redirection

در صفحه تنظیمات این پلاگین، به‌دلیل عدم وجود فیلتر مناسب در هنگام دریافت ورودی از کاربر، امکان اجرای حمله Reflected XSS فراهم است.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری RCE در پلاگین WP Super Cache

به دلیل عدم اعتبارسنجی ورودی‌ها و همچنین ضعف امنیتی در بررسی متغیر $cache_path که در تنظیمات این پلاگین وجود دارد، یک کاربر با سطح دسترسی ادمین و بالاتر می‌تواند به فایل wp-cache-config.php به طور مستقیم دسترسی پیدا کرده و در آن وب شل تزریق کند.

نسخه‌های آسیب پذیر در این پلاگین: ۱.۷.۲ و ما قبل آن

آسیب پذیری SQL Injection در پلاگین Tutor LMS

این آسیب پذیری، به پنج صورت در پلاگین Tutor LMS خود را نشان می‌دهد:

  1. در این پلاگین آسیب پذیری SQL Injection از نوع union based کشف شده است و دانش آموزان امکان اجرای این حمله را خواهند داشت. (نسخه‌های آسیب پذیر در این پلاگین: ۱.۸.۳ و ما قبل آن)
  2. عملیات AJAX در بخش tutor_place_rating این پلاگین، دارای آسیب پذیری SQL Injection از نوع blind and time based است. به همین خاطر دانش آموزان قادر به سوءاستفاده از این آسیب پذیری خواهند بود. (نسخه‌های آسیب پذیر در این پلاگین: ۱.۷.۷ و ما قبل آن)
  3. در عملیات AJAX مربوط به tutor_quiz_builder_get_question_form آسیب پذیری SQL Injection از نوع union based کشف شده است که دانش آموزان امکان اجرای آن را خواهند داشت. (نسخه‌های آسیب پذیر در این پلاگین: ۱.۸.۳ و ما قبل آن)
  4. در عملیات AJAX مربوط به tutor_quiz_builder_get_answers_by_question آسیب پذیری SQL Injection از نوع union based کشف شده است. دانش آموزان امکان اجرای آن را خواهند داشت. (نسخه‌های آسیب پذیر در این پلاگین: ۱.۸.۳ و ما قبل آن)
  5. در عملیات AJAX مربوط به tutor_mark_answer_as_correct آسیب پذیری SQL Injection از نوع blind and time based کشف شده است که دانش آموزان امکان اجرای آن را خواهند داشت. (نسخه‌های آسیب پذیر در این پلاگین: ۱.۷.۷ و ما قبل آن)

آسیب پذیری Unprotected AJAX در پلاگین Tutor LMS

برخی از AJAX endpoint ها در این پلاگین، محافظت نشده هستند و به دانش آموزان اجازه تغییر اطلاعات درس و همچنین بالا بردن سطح دسترسی را می‌دهد.

نسخه های آسیب پذیر در این پلاگین: ۱.۷.۷ و ما قبل آن

آسیب پذیری XSS در پلاگین Related Posts for WordPress

پارامتر lang که از نوع GET محسوب می‌شود، در هنگام ویرایش یک پست، به دلیل عدم اعتبارسنجی ورودی‌ها، دارای آسیب پذیری Reflected XSS است.

نسخه‌های آسیب پذیر در این پلاگین: ۲.۰.۴ و ما قبل آن

آسیب پذیری XSS در پلاگین Social Slider Widget

یک کاربر که به پیشخوان وردپرس دسترسی دارد، به دلیل عدم فیلتر مناسب در پارامتر token_error که در بخش تنظیمات این پلاگین وجود دارد، امکان اجرای حمله Reflected XSS را خواهد داشت.

نسخه‌های آسیب پذیر در این پلاگین: ۱.۸.۵ و ما قبل آن

آسیب پذیری CSRF در پلاگین VM Backups

پلاگین VM Backups به دو صورت از آسیب پذیری CSRF تاثیر می‌گیرد:

  1. این پلاگین فاقد CSRF check است و همین موضوع به هکر اجازه می‌دهد تا برخی اقدامات مانند تغییر option های پلاگین را بر روی یک کاربر login شده انجام دهد. این موضوع می‌تواند به اجرای حمله Stored XSS نیز ختم شود.
  2. این پلاگین فاقد CSRF check است و همین موضوع به هکر اجازه می‌دهد تا برخی اقدامات مانند ایجاد بکاپ از فایل‌های دیتابیس، پلاگین‌ها و قالب را بر روی یک کاربر login شده انجام دهد. این فایل‌های بکاپ به صورت پیش‌فرض، همراه با timestamps در نام خود، بدون هیچ‌گونه محدودیت دسترسی، در پوشه uploads قرار می‌گیرند و هکر می‌تواند به‌راحتی به آن‌ها دسترسی داشته باشد. همچنین این فایل‌ها می‌توانند به کمک حمله CSRF، به ایمیل مدنظر هکر ارسال شوند.

نسخه‌های آسیب پذیر در این پلاگین برای هر دو حالت: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری XSS در پلاگین JH 404 Logger

در این پلاگین، referrer و مسیر صفحات ۴۰۴ (صفحاتی که یافت نمی‌شوند) sanitize نمی‌شوند و این موضوع منجر به حمله Stored XSS می‌شود.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری PHP Object Injection در پلاگین Five Star Restaurant Menu

در این پلاگین مقدار fdm_cart که در cookie وجود دارد، بدون اینکه ابتدا sanitize یا اعتبارسنجی شود، در هنگام فعال بودن تنظیمات Ordering، باعث اجرای حمله PHP Object Injection می‌شود که در نهایت می‌تواند منجر به RCE گردد.

نسخه‌های آسیب پذیر در این پلاگین: ۲.۲.۱ و ما قبل آن

آسیب پذیری CSRF در پلاگین Database Backups

این پلاگین فاقد CSRF check است! همین موضوع به هکر اجازه می‌دهد تا بتواند یک کاربر login شده را وادار کند تا برخی اقدامات مانند ایجاد بکاپ از دیتابیس، حذف بکاپ دیتابیس و تغییر تنظیمات پلاگین را انجام دهد.

بکاپ ایجاد شده در مسیر wp-content/uploads/database-backups قرار می‌گیرد و نام آن با فرمتی است که تاریخ ایجاد بکاپ نیز در آن نوشته می‌شود. این مسیر بدون محدودیت در دسترس است و هکر به‌راحتی می‌تواند به آن دسترسی داشته باشد.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری SQL Injection در پلاگین SuperStoreFinder & SuperInteractiveMaps

فایل‌های ssf-social-action.php و sim-wp-data.php در این پلاگین‌ها به دلیل عدم sanitize کردن ورودی‌های کاربر قبل از ارسال query، دارای چند آسیب پذیری SQL Injection هستند.

پلاگین‌ها و نسخه‌های آسیب پذیر:

SuperStoreFinder-wp —— رفع شده در نسخه ۶.۵

Super-Interactive-Maps —— رفع شده در نسخه ۲.۲

آسیب پذیری Authentication Bypass در پلاگین The Plus Addons for Elementor Page Builder

آسیب پذیری موجود در این پلاگین، به‌طور گستره در حال سواستفاده توسط هکرها بوده و با استفاده از آن، هکرها می‌توانند حتی در صورت غیرفعال بودن registration و Login widget، احراز هویت را دور بزنند و به عنوان هر user دلخواه وارد حساب کاربری آن شوند (این موضوع شامل admin هم می‌شود)؛ همچنین آن‌ها می‌توانند اکانت‌های دلخواه با سطح دسترسی admin نیز ایجاد کنند.

نسخه‌های آسیب پذیر در این پلاگین: ۴.۱.۷ و ما قبل آن

آسیب پذیری File Upload در پلاگین WooCommerce Upload Files

این پلاگین یک مرحله sanitization برای حذف extensionهای غیرمجاز (مانند .php) را اجرا می‌کند. این امکان وجود دارد که این sanitization با اضافه کردن یک extension غیرمجاز به دنبال extension غیرمجاز دیگر، در پارامتر wcuf_file_nameدور زده شود. همچنین امکان آپلود فایل‌ها به روش double extension attack نیز در پارامتر wcuf_current_upload_session_id فراهم است.

نسخه‌های آسیب پذیر در این پلاگین: ۵۹.۴ و ما قبل آن

آسیب پذیری Sensitive Information Disclosure در پلاگین User Profile Picture

get_users که یک REST API endpoint در این پلاگین است، اطلاعاتی بیش از حدِ مورد نیاز به کاربرانی که قابلیت upload_files را داشته باشند نشان می‌دهد. این اطلاعات شامل پسوردهای هش شده، activation key های هش شده کاربران، نام‌های کاربری، ایمیل‌ها و اطلاعات دیگر است.

نسخه‌های آسیب پذیر در این پلاگین: ۲.۵.۰ و ما قبل آن

آسیب پذیری XSS در پلاگین Advanced Order Export For WooCommerce

این پلاگین که به شما کمک می‌کند تا به راحتی اطلاعات سفارشات woocommerce را export کنید، در پنل مدیریت آن و پارامتر tab، آسیب پذیری Reflected XSS کشف شده است.

نسخه‌های آسیب پذیر در این پلاگین: ۳.۱.۸ و ما قبل آن

آسیب پذیری XSS در پلاگین WP GDPR Compliance

در پنل مدیریت این پلاگین، آسیب پذیری Stored XSS کشف شده است که می‌تواند منجر به ارتقای سطح دسترسی شود. آسیب پذیری مذکور به این دلیل ایجاد شده است که IP Addressهای کلاینت‌ها در پیشخوان این پلاگین، بدون اعتبارسنجی مناسب reflect می‌شوند.

نسخه‌های آسیب پذیر در این پلاگین: ۱.۵.۶ و ما قبل آن

آسیب پذیری CSRF Nonce Bypass در چند پلاگین

در طی بررسی‌های انجام شده بر روی چند پلاگین، مشخص می‌شود که در آن‌ها CSRF nonce به خوبی بررسی نمی‌شود! این موضوع به هکر اجازه می‌دهد تا کاربران login شده را به ارسال درخواست‌های دست‌کاری شده وادار کنند. به این ترتیب هکرها برخی از اعمال دلخواه‌شان را به‌وسیلۀ این کاربران انجام دهند. در ادامه این پلاگین‌های آسیب پذیر را معرفی می‌کنیم:

پلاگین‌ها و نسخه‌های آسیب پذیر:

Forminator —— رفع شده در نسخه ۱.۱۴.۸.۱

Dokan-lite —— رفع شده در نسخه ۳.۲.۱

Defender-Security —— رفع شده در نسخه ۲.۴.۶.۱

WooCommerce-Abandoned-Cart —— رفع شده در نسخه ۵.۸.۶

Analogwp-Templates —— رفع شده در نسخه ۱.۸.۱

ERP —— رفع شده در نسخه ۱.۷.۵

Wedevs-Project-Manager —— رفع شده در نسخه ۲.۴.۱۰

WP-Travel —— رفع شده در نسخه ۴.۴.۷

همان‌طور که دیدید، بیشتر آسیب پذیری‌های کشف شده، در پلاگین‌های این CMS وجود داشتند؛ اما برخی از آسیب پذیری‌ها هم در تم‌های وردپرس پیدا شده‌اند.

آسیب پذیری‌های کشف شده در تم‌های وردپرس

در ادامه متن راجع به دو آسیب‌ پذیری کشف شده در تم‌های وردپرسی خواهیم گفت:

آسیب پذیری XSS در تم Goto-Tour & Travel

پارامترهای keywords و start_date در صفحه Tour List این پلاگین فیلتر نمی‌شوند. این موضوع امکان اجرای حمله Reflected XSS را فراهم می‌کند.

نسخه‌های آسیب پذیر در این تم: ۲.۰ و ما قبل آن

آسیب پذیری XSS در تم Business Directory

در این تم، ورودی‌های کاربر در بخش search آن sanitize نمی‌شوند و امکان حمله Reflected XSS در آن وجود دارد.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

جمع‌بندی

اگر می‌خواهید سایت‌ وردپرسی‌تان دچار مشکلات مختلف امنیتی نشود، حتماً باید مواردی که در این مقاله به آن‌ها اشاره کرده‌ایم را مدنظر داشته باشید.

اگر از هرکدام از افزونه‌ها یا پلاگین‌هایی که بالاتر از آن‌ها نام بردیم و به نقص‌های‌شان اشاره کردیم، استفاده می‌کنید، سریعاً آن‌ها را به‌روزرسانی کنید تا سایت‌تان به خطر نیفتد!

امتیاز این نوشته

امتیاز

امتیاز کاربران: 4.4 ( 6 رای)

مشاهده بیشتر

نوشته های مشابه

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

دکمه بازگشت به بالا